× Auto Repair Pros Member Benefits TechHelp Knowledge Base Forums Resources My iATN Marketplace Chat Pricing About Us Join Industry Sponsors Video Members Only Repair Shops Auto Pro Careers Auto Pro Reviews
Join Now
International Automotive Technicians Network

Automotive Technical Discussion Forum

Professional automotive forum for all types of vehicle repair discussion that does not fit into one of our more specific technical forums. Discussions include both OBD and OBD2, engine performance analysis, diagnostic best practices, service information, vehicle standards such as J1962, J1939, J2534, OBD2 modes (e.g. MODE$06), ignition and fuel system analysis, alternative propulsion (e.g. hybrid, electric, natural gas), and more. This forum is for experienced automotive repair professionals only, membership required.

Continue to the description of our next automotive discussion forum, the Technical Theory Forum.

Recent Automotive Discussions in the Automotive Technical Discussion Forum

CKP waveform and misfire
05/24/2019 in the Technical Discussion Forum
[Driveability: 98 Jeep Cherokee Classic 4.0L] Good Morning, This Jeep experiences a random misfire under most conditions. It may run well for ten of fifteen minutes and then have a single or multiple events. At first I thought it was always occurring on ...
C11 Cat IVA Issues
05/24/2019 in the Technical Discussion Forum
I have C11 Cat that has low power....codes for IVA unresponsive on #6. Swapped solenoids, still on #6. Moved IVA assembly from #5 & 6 to #1 & 2. Adjusted valves, injectors, and IVA. Problem moves to #2. Replaced IVA assembly with Cat Reman unit. Stil...
3.5 Eco coolant leak
05/24/2019 in the Technical Discussion Forum
[Engine: 14 Ford F-150 Platinum 3.5L] The LH turbo has a coolant leak from one of the quick connect fittings. I assume there are 2 fittings on the turbo and 2 on the engine. how hard are these to change and what do I have to be careful of? I would hate t...
Tacoma acceleration lag
05/23/2019 in the Technical Discussion Forum
[Driveability: 05 Toyota Tacoma 4.0L] Trying to make sure I don't miss anything here. I've got this Tacoma with a noticeable lag in acceleration. When you punch the throttle it will bog and sometimes backfire before building up and finally revving. It se...
ECM Ground
05/22/2019 in the Technical Discussion Forum
[Electrical: 05 Chevrolet Equinox LT 3.4L] Hey guys, I put a used engine in this vehicle and when I went to start it it wouldn't crank. The bcm was setting ecm & tcm lost communication codes. I scratched my head, double checked the wire connections and s...

Automotive Sponsored Discussion Forums