× Auto Repair Pros Member Benefits TechHelp Knowledge Base Forums Resources My iATN Marketplace Chat Pricing About Us Join Industry Sponsors Video Members Only Repair Shops Auto Pro Careers Auto Pro Reviews
Join Now
International Automotive Technicians Network

Automotive HD/Fleet Forum

Professional automotive forum for discussion of heavy-duty trucks, buses and other on- and off-road equipment, and maintenance of automotive fleet vehicles. Discussion topics include fuels and lubricants, hydraulics, performance, on-board diagnostics, powertrain, power distribution, anti-lock braking and stability control systems, and best practices as they relate to heavy duty and fleet maintenance. This forum is for experienced automotive repair professionals only, membership required.

Continue to the description of our next automotive discussion forum, the HVAC Forum.

Recent Automotive Discussions in the Automotive HD/Fleet Forum

1964 ih scout
05/12/2021 in the HD/Fleet Forum
Does anyone recall wiring diagram for old delco alternator with external regulator? Black 4 term regulator. Term 1 field, Term 2 r from alt, term 3 ign, term 4 battery sound right? idiot light in series with term 2? I can get it to charge but a bit foggy ...
2018 Western Star J1939 250K Performance Central Gateway
05/11/2021 in the HD/Fleet Forum
VIN: 2018 Western Star 4700SF Vin: [...] Engine: DD13 SPN-523512 FMI-31. I need help... Truck is running fine, perfectly but I have no gages. No speedometer, tech, air pressure, oil pressure, def fluid level, nothing, but the truck runs fine. I connect th...
Fan Staying On
05/11/2021 in the HD/Fleet Forum
[Engine: 02 International 2674 12.0L] CUMMINS N14 CELECT PLUS -Customer complaint fan is always on Checked for codes- none Checked system, key on fan is free, engine running fan always on Checked data with Insite. Fan clutch 1 says "on" at all times. I ...
Case 580M 3.9 Cummins
05/05/2021 in the HD/Fleet Forum
This backhoe has an inline Cummins 3.9 B series diesel with a Bosch inline injection pump, with kill solenoid. It starts easily and runs for about 3 seconds and dies. No problem starting again, but it does the same thing. If I hold the kill lever in the r...
GAUGES
05/03/2021 in the HD/Fleet Forum
[Electrical: 00 International 4900 7.6L] This truck seems to have the common gauge sweep, then won't work, then work fine problem, but i haven't found a common cause, the circuit board has been change and was burnt, it seem to also be affected at times b...

Automotive Sponsored Discussion Forums