Join Now
International Automotive Technicians Network

P0340 Diagnostic Trouble Code Discussion for March 2010

CMP Sensor Circuit Malfunction


Note: This is a professional automotive technician's resource.
Vehicle Owners: If you are seeking an automotive repair professional to service your vehicle, visit the iATN Repair Shop Finder.

Trouble Ticket Help Requests for DTC P0340
Help Request Posted
1997 GMC K2500 Sierra SL 5.7L MIL Lamp on VIN: 1GTGK24R4V
P0340: CMP Sensor Circuit Malfunction. this is a strange problem. came in with a cel checked and found the codes listed above. traced down and found the eng 1 fuse blown 20 amp according to the wiring diagram it controls the heated o2 sensors and egr valve canister purge valve cam and crank sensors...
March 02, 2010
2000 Dodge Intrepid 2.7L No Start, MIL Lamp on, long crank time VIN: 2B3HD46R3Y
P0340: No Camshaft Sensor Signals At PCM. after replacing water pump & timing parts, ect vehicle will only run if cam sensor is unpluged. Have repalced cam sensors twice, still same problem. Thank You For any help!!
March 04, 2010
2003 Jeep Liberty Sport 3.7L No Start, Stall
P0340: Camshaft Position Sensor Circuit Malfunction. ... in on the hook with the p0340 for the cam sensor. It started right up and i drove it when it came in and could not get it to act up so i replaced the cam sensor.now it randomly stalls and sometimes will start right back up, sometimes it won't it only dies ...
March 04, 2010
2004 Nissan Sentra S 1.8L Poor Idle Quality, Hesitation, Surge, Stall, MIL Lamp on VIN: 3N1CB51D14
P0340: Camshaft Position Sensor Circuit Malfunction (Bank 1). ... engine will buck and hesitate severely and may even stall. Sometimes for several minutes but sometimes only a few seconds. once it stops acting up and is warm it will run like a new one for the rest of the day. Code p0340 is the only code ever set. (cam po...
March 09, 2010
2002 Jeep Grand Cherokee Laredo 4.0L No Start, Stall, MIL Lamp on VIN: 1J4GW48SX2
P0340: No Camshaft Sensor Signals At PCM. ... came out. New crank sensor installed. Coil asm installed. Still no start. Well when first came in it had codes P0122 TPS,P1495 LDP, P0340 No cam signal. Cleared codes. Cranked to see what ...
March 22, 2010
2002 Dodge Intrepid SE 2.7L Poor Idle Quality, Hesitation, Misfire, MIL Lamp on VIN: 2B3HD46R92
P0340: No Camshaft Sensor Signals At PCM. vehicle came in with misfire, rough idle and hesitation at all times. retrieved po340, po152, and po300. replaced dead bank 2 sensor 1 o2 sensor. replaced cam sensor, sprak plugs. also replaced intake gaskets (all0 after spray determined they were leaking on b...
March 23, 2010
1997 Mazda B2300 2.3L Cuts out VIN: 4F4CR12A1V
P0340: Camshaft Position Sensor Circuit Malfunction. vehicle runs good ,but just cuts out when driving. initially it would die intermittently & we replaced tps & this problem was solved.It has constant reading of 5 volts on the tps,iat,tps,o2,& cps reads faulty all the time.Suspect computer is bad as...
March 29, 2010
1995 Ford Ranger XL 3.0L Surge VIN: 1FTCR1OU6S
P0340: cam positionsensor. I PUT THE CAM SENSOR NEW IT WAS BROKEN AND THE THERMOSTAT IT WAS ALWAYS COLD BELOW C LINE COLD. THE SCOPE ON CAM AND CRANK SENSOR TELL ME THAT THE CAM IS OUT BY 130 DEGREES IT DOESTN'T LINE UP WITH THE 26% DEGREES ATDC LIKE IT SHOULD. THE EGR PASSAGE IS CLEAN ...
March 30, 2010
2003 Mazda 6 S 3.0L Stall, MIL Lamp on VIN: 3MA3941434
P0340: Camshaft Position Sensor Circuit Malfunction. first i want to thank all for your responses and apologize if the info is not complete. This is my personal car and it does has a oil comsumption problem. i add a quart of oil once a month. i belive it is from #1 cylinder because i had a p0301 last week and wh...
March 30, 2010
1997 GMC K2500 Sierra SL 5.7L MIL Lamp on VIN: 1GTGK24R4V
P0340: CMP Sensor Circuit Malfunction. this is a strange problem. came in with a cel checked and found the codes listed above. traced down and found the eng 1 fuse blown 20 amp according to the wiring diagram it controls the heated o2 sensors and egr valve canister purge valve cam and crank sensors...
March 02, 2010
2000 Dodge Intrepid 2.7L No Start, MIL Lamp on, long crank time VIN: 2B3HD46R3Y
P0340: No Camshaft Sensor Signals At PCM. after replacing water pump & timing parts, ect vehicle will only run if cam sensor is unpluged. Have repalced cam sensors twice, still same problem. Thank You For any help!!
March 04, 2010
2003 Jeep Liberty Sport 3.7L No Start, Stall
P0340: Camshaft Position Sensor Circuit Malfunction. ... in on the hook with the p0340 for the cam sensor. It started right up and i drove it when it came in and could not get it to act up so i replaced the cam sensor.now it randomly stalls and sometimes will start right back up, sometimes it won't it only dies ...
March 04, 2010
2004 Nissan Sentra S 1.8L Poor Idle Quality, Hesitation, Surge, Stall, MIL Lamp on VIN: 3N1CB51D14
P0340: Camshaft Position Sensor Circuit Malfunction (Bank 1). ... engine will buck and hesitate severely and may even stall. Sometimes for several minutes but sometimes only a few seconds. once it stops acting up and is warm it will run like a new one for the rest of the day. Code p0340 is the only code ever set. (cam po...
March 09, 2010
2002 Jeep Grand Cherokee Laredo 4.0L No Start, Stall, MIL Lamp on VIN: 1J4GW48SX2
P0340: No Camshaft Sensor Signals At PCM. ... came out. New crank sensor installed. Coil asm installed. Still no start. Well when first came in it had codes P0122 TPS,P1495 LDP, P0340 No cam signal. Cleared codes. Cranked to see what ...
March 22, 2010
2002 Dodge Intrepid SE 2.7L Poor Idle Quality, Hesitation, Misfire, MIL Lamp on VIN: 2B3HD46R92
P0340: No Camshaft Sensor Signals At PCM. vehicle came in with misfire, rough idle and hesitation at all times. retrieved po340, po152, and po300. replaced dead bank 2 sensor 1 o2 sensor. replaced cam sensor, sprak plugs. also replaced intake gaskets (all0 after spray determined they were leaking on b...
March 23, 2010
1997 Mazda B2300 2.3L Cuts out VIN: 4F4CR12A1V
P0340: Camshaft Position Sensor Circuit Malfunction. vehicle runs good ,but just cuts out when driving. initially it would die intermittently & we replaced tps & this problem was solved.It has constant reading of 5 volts on the tps,iat,tps,o2,& cps reads faulty all the time.Suspect computer is bad as...
March 29, 2010
1995 Ford Ranger XL 3.0L Surge VIN: 1FTCR1OU6S
P0340: cam positionsensor. I PUT THE CAM SENSOR NEW IT WAS BROKEN AND THE THERMOSTAT IT WAS ALWAYS COLD BELOW C LINE COLD. THE SCOPE ON CAM AND CRANK SENSOR TELL ME THAT THE CAM IS OUT BY 130 DEGREES IT DOESTN'T LINE UP WITH THE 26% DEGREES ATDC LIKE IT SHOULD. THE EGR PASSAGE IS CLEAN ...
March 30, 2010
2003 Mazda 6 S 3.0L Stall, MIL Lamp on VIN: 3MA3941434
P0340: Camshaft Position Sensor Circuit Malfunction. first i want to thank all for your responses and apologize if the info is not complete. This is my personal car and it does has a oil comsumption problem. i add a quart of oil once a month. i belive it is from #1 cylinder because i had a p0301 last week and wh...
March 30, 2010