Join Now
International Automotive Technicians Network
Chrysler PCI Bus Problem
Posted to Technical Discussion Forum on 9/5/2017 15 Replies

Customer was driving vehicle when "many dash lights" came on. He went home and disconnected the battery and when he reconnected it "No Bus" displayed on dash as well as instrument cluster, door locks, some windows quit working.

When the vehicle came in the following codes were present: P0522, U0140, U110C, U0101, U0168, U0155. The instrument cluster is inoperative (no lights, gauges, etc) with the exception of the turn signal lights are working. Rear liftgate will not open, door locks inop. Vehicle runs fine.

I performed a battery disconnect and cleaned battery terminals. There was a lot of battery acid present. The PCI bus at the DLC is showing very low voltage no matter which module is unplugged. [2005 Chrysler Pacifica, ECM/Inputs/Outputs Waveform] When I unplugged connectors C1, C4, and C6 from the IPDM I am getting this waveform at the IPDM [2005 Chrysler Pacifica Touring, ECM/Inputs/Outputs Waveform] . With just the C4 connector unplugged I am getting this waveform [2005 Chrysler Pacifica, ECM/Inputs/Outputs Waveform] . I have unplugged the following modules with no change: PCM, BCM, IPC, EBCM, DDM, PDM, Radio, CD, HVAC, SKREEM.

Damon Agostino
Technician
Sixth Street Automotive
Macclenny, Florida, USA

Files Referenced:

thumbnail thumbnail thumbnail

15 Replies Received (View Replies)

 

car Vehicle Data

2005 Chrysler Pacifica Touring 3.5L

VIN 2C4GM68405
Engine3.5 L
Trans4-speed Automatic (Electronic)