Join Now
International Automotive Technicians Network
Posted to Technical Tips Forum on 10/4/2014 7 Replies

I searched the data base and could not find this one, so here goes. Vehicle came in with tire pressure sensor light on, not flashing. Reset all tire pressures, hit button in glove box, tire pressure light blinked 3 times and came right back on. Scanned for codes, I had a c2121 - no signal from transmitter ID1 in main mode.

Using my TPMS3, I checked all the sensors and had 2 dead left side sensors. Installed 2 new sensors, retrieved the sensor codes with the TPMS3 and tried to upload them. I got a "Transfer Failure" message. I was also not able to clear the c2121 and I had no code for the other dead sensor.

After trying multiple was to program (including manually entering the codes with the solus) and being unsuccessful, I found T-SB-0084-09, which states when using Techstream, if you get a loss of communication message while programming TPMS, jumper ALDL pins 4 & 13 with the key on for at least 30 seconds with the key on, then remove fused jumper, and proceed with programming.

I wasn't using a Techstream and I did not seem to be loosing communication with the module, but I figured it was worth a try. It worked like a charm. I was able to program the sensors and clear the codes from the module. Hope this helps someone.

Todd from New Jersey

7 Replies Received (View Replies)


car Vehicle Data

2007 Toyota Camry LE 2.4L

Engine2.4 L
Trans5-speed Automatic (Electronic)