Join Now
International Automotive Technicians Network

P0340 Diagnostic Trouble Code Discussion for May 2014

CMP Sensor Circuit Malfunction


Note: This is a professional automotive technician's resource.
Vehicle Owners: If you are seeking an automotive repair professional to service your vehicle, visit the iATN Repair Shop Finder.

Trouble Ticket Help Requests for DTC P0340
Help Request Posted
2000 Ford F-250 Super Duty Lariat 7.3L No Start VIN: 1FTNX21F3Y
P0340: Camshaft Position Sensor Circuit Malfunction. Hello fellow techs, thanks in advance for taking the time to read about my problem. The customer had this truck towed to my facility after it failed to start after stalling. The customer stated the truck was losing engine power over ten miles or so and finally...
May 10, 2014
2009 Infiniti G37 X 3.7L No Start VIN: JNKCV61F69
P0340: Cam Position Sensor Bank One. Timing was off one tooth and would not run at all with cam sensor bank 1 pluged in, now repaired. Car will start only with bank 1 cam sensor unpluged but will continue to run with sensor re-connected now. Cam phaser appears to function properly when activating...
May 14, 2014
2005 Volvo XC90 2.5T 2.5L No Start, MIL Lamp on VIN: YV1CY59265
P0340: cam position sensor signal missing intake. Checked Cam Sensor Signal From Intake Cam (good) Checked Cam Timing (good) Checked Crankshaft Sprocket For Torque (good) Fount End Play It Both Cam Sprockets The Exhaust Is Worse Will This Give Me The Code And Keep The Car From Starting?
May 15, 2014
2003 Nissan Altima 2.5L No Start, MIL Lamp on VIN: 1N4AL11DX3
P0340: Camshaft Position Sensor (Phase) Circuit Malfunction. I have a problem 2003 Altima, no start on hot soak. When I first got the car, I could not duplicate. Put in a cam and crank sensor, then problem appeared and is getting worse. I used Napa sensors, first the plastic sensor, then the metal sensor. Did not help. ...
May 16, 2014
1997 Volvo 850 2.4L No Start, Stall VIN: YV1LW5549V
P0340: Camshaft position sensor. Okay all my Volvo mechanics. I hope you all had a great Memorial Day week-end because I need you to help me get this sick Volvo 850 wagon back to his family. What happens is the wagon will run beautiful for several miles and then all of a sudden will start to ...
May 28, 2014
2001 Chrysler 300M 3.5L No Start, Stall
P0340: No Camshaft Sensor Signals At PCM. Please, I need mopar guru! Car will start& run with cam sensor unplugged but not well. Pretty sure cam timing is on mark because of good compression. Pulled plenum to replace gasket and ran new signal wire from sensor to pcm. Any help appreciated. Car idle...
May 29, 2014