Join Now
International Automotive Technicians Network

P0321 Diagnostic Trouble Code Discussion for April 2014

Crankshaft Position Sensor Circuit Range/Performance


Note: This is a professional automotive technician's resource.
Vehicle Owners: If you are seeking an automotive repair professional to service your vehicle, visit the iATN Repair Shop Finder.

Trouble Ticket Help Requests for DTC P0321
Help Request Posted
2004 Volkswagen Passat GLS 1.8L No Start VIN: WVWPD63B34
P0321: Crank/engine speed sensor. Please help. We have replaced the crank sensor.car started and ran for a day and a half. towed back in and started and now no start. checked the a/c current from the crank sensor. all with in specs. still have no spark or injector pulse. checked all the ground...
April 04, 2014
2004 Volkswagen Passat GLS 1.8L No Start VIN: WVWPD63B34
P0321: Crank/engine speed sensor. Please help. We have replaced the crank sensor.car started and ran for a day and a half. towed back in and started and now no start. checked the a/c current from the crank sensor. all with in specs. still have no spark or injector pulse. checked all the ground...
April 04, 2014
2004 Volkswagen Passat GLS 1.8L No Start VIN: WVWPD63B34
P0321: Crank/engine speed sensor. Please help. We have replaced the crank sensor.car started and ran for a day and a half. towed back in and started and now no start. checked the a/c current from the crank sensor. all with in specs. still have no spark or injector pulse. checked all the ground...
April 04, 2014
2004 Volkswagen Passat GLS 1.8L No Start VIN: WVWPD63B34
P0321: Crank/engine speed sensor. Please help. We have replaced the crank sensor.car started and ran for a day and a half. towed back in and started and now no start. checked the a/c current from the crank sensor. all with in specs. still have no spark or injector pulse. checked all the ground...
April 04, 2014
2004 Volkswagen Passat GLS 1.8L No Start VIN: WVWPD63B34
P0321: Crank/engine speed sensor. Please help. We have replaced the crank sensor.car started and ran for a day and a half. towed back in and started and now no start. checked the a/c current from the crank sensor. all with in specs. still have no spark or injector pulse. checked all the ground...
April 04, 2014