Join Now
International Automotive Technicians Network

P0340 Diagnostic Trouble Code Discussion for February 2010

CMP Sensor Circuit Malfunction


Note: This is a professional automotive technician's resource.
Vehicle Owners: If you are seeking an automotive repair professional to service your vehicle, visit the iATN Repair Shop Finder.

Trouble Ticket Help Requests for DTC P0340
Help Request Posted
2005 Nissan Sentra S 1.8L Hesitation, Surge, Cuts out, MIL Lamp on VIN: 3N1CB51D45
P0340: Camshaft Position Sensor Circuit Malfunction (Bank 1). I have seen maf sensor cause this on maximas and pathfinders. It bucks mostly when cold, but she says its starting to do it more after warm up.My snapon brick only goes to 04 so I am limitted on what I can see on this car. Called the dealer and they said no pr...
February 02, 2010
1997 Saturn SL1 1.9L MIL Lamp on VIN: 1G8ZH528SV
P0340: Camshaft Position Sensor Circuit Malfunction. This car keeps setting a P0340 code intermittently upon start-up. Started shortly after it had a tune-up with aftermarket wires. Apon viewing TSB's and IATN, we replaced ignition wires with OE. 3 days later it returned with same code. We then installed new ign...
February 09, 2010
2000 Ford F-150 4.2L Misfire, MIL Lamp on VIN: 1FT2X1729Y
P0340: cam sync. This truck has good start and idle. On accel the engine will start to missfire. The o2 sensors go to 0 it throws the cam sensor code. I have checked the data base and tried unpluging the alternator,egr,dpfe sensor,checked balancer for play. Not really sure whi...
February 11, 2010
2003 Nissan Sentra GXE 1.8L Poor Idle Quality, Hesitation, Cuts out, Stall, Misfire VIN: 3N1CB51D53
P0340: Camshaft Position Sensor Circuit Malfunction. Sorry all! Posted this vehicle as fixed. Old ECU had signs of water intrusion with whitish deposits on cover and inside on and around circuit board. Replaced with new from dealer, ran fine. Parked vehicle. Same old puttering during warm up, will not rev over 2...
February 12, 2010
2005 Nissan Sentra S 1.8L Hesitation, Surge, Cuts out, MIL Lamp on VIN: 3N1CB51D45
P0340: Camshaft Position Sensor Circuit Malfunction (Bank 1). I have seen maf sensor cause this on maximas and pathfinders. It bucks mostly when cold, but she says its starting to do it more after warm up.My snapon brick only goes to 04 so I am limitted on what I can see on this car. Called the dealer and they said no pr...
February 12, 2010
2003 Nissan Sentra GXE 1.8L Poor Idle Quality, Hesitation, Cuts out, Stall, Misfire VIN: 3N1CB51D53
P0340: Camshaft Position Sensor Circuit Malfunction. Sorry all! Posted this vehicle as fixed. Old ECU had signs of water intrusion with whitish deposits on cover and inside on and around circuit board. Replaced with new from dealer, ran fine. Parked vehicle. Same old puttering during warm up, will not rev over 2...
February 15, 2010
1996 Dodge Intrepid 3.3L No Start VIN: 2B3HD46T4T
P0340: No Camshaft Sensor Signals At PCM. this intrepid will start right up cold{0 to 10 degrees} when warming up will shut off suddenly,when warm in shop will never start.sets code for cam sensor when dies.replaced sensor no help.cam and crank have refrence power and ground.when trying to start scann...
February 18, 2010
1997 Plymouth Voyager SE 3.3L No Start, MIL Lamp on VIN: 1B4GP45R5V
P0340: No Camshaft Sensor Signals At PCM. Gentlemen, Van towed in , has good fuel pressure and the asd circuit working properly, has spark to 2/5 coil 3 times then dissapears ,1 spark from 1/4 coil and none from3/6 coil I can tell this 3 ways, from the driver wires at the coil , from the spark plugs a...
February 18, 2010
1997 Plymouth Voyager SE 3.3L No Start, MIL Lamp on VIN: 1B4GP45R5V
P0340: No Camshaft Sensor Signals At PCM. Gentlemen, Van towed in , has good fuel pressure and the asd circuit working properly, has spark to 2/5 coil 3 times then dissapears ,1 spark from 1/4 coil and none from3/6 coil I can tell this 3 ways, from the driver wires at the coil , from the spark plugs a...
February 19, 2010
1999 Land Rover Discovery SD 4.0L No Start VIN: SALTY1242X
im not getting a ground signal from the ecm for the main relay is this a common problem with this vehicle and when this happens my cooling fan willnot shut off (like bad ecm)
February 22, 2010
2002 Dodge Ram 1500 Van 3.9L Poor Idle Quality, MIL Lamp on VIN: 2B6HB11XX2
P0340: No Camshaft Sensor Signals At PCM. The customer has been driving the van since replacing the sensor with only a loss of power one time.Like I stated earlier I ohmed out the harness and it checks out OK and did a wiggle test and everything is also fine.I was wondering if anybody knows of any kno...
February 24, 2010
2005 Nissan Sentra S 1.8L Hesitation, Surge, Cuts out, MIL Lamp on VIN: 3N1CB51D45
P0340: Camshaft Position Sensor Circuit Malfunction (Bank 1). I have seen maf sensor cause this on maximas and pathfinders. It bucks mostly when cold, but she says its starting to do it more after warm up.My snapon brick only goes to 04 so I am limitted on what I can see on this car. Called the dealer and they said no pr...
February 02, 2010
1997 Saturn SL1 1.9L MIL Lamp on VIN: 1G8ZH528SV
P0340: Camshaft Position Sensor Circuit Malfunction. This car keeps setting a P0340 code intermittently upon start-up. Started shortly after it had a tune-up with aftermarket wires. Apon viewing TSB's and IATN, we replaced ignition wires with OE. 3 days later it returned with same code. We then installed new ign...
February 09, 2010
2000 Ford F-150 4.2L Misfire, MIL Lamp on VIN: 1FT2X1729Y
P0340: cam sync. This truck has good start and idle. On accel the engine will start to missfire. The o2 sensors go to 0 it throws the cam sensor code. I have checked the data base and tried unpluging the alternator,egr,dpfe sensor,checked balancer for play. Not really sure whi...
February 11, 2010
2003 Nissan Sentra GXE 1.8L Poor Idle Quality, Hesitation, Cuts out, Stall, Misfire VIN: 3N1CB51D53
P0340: Camshaft Position Sensor Circuit Malfunction. Sorry all! Posted this vehicle as fixed. Old ECU had signs of water intrusion with whitish deposits on cover and inside on and around circuit board. Replaced with new from dealer, ran fine. Parked vehicle. Same old puttering during warm up, will not rev over 2...
February 12, 2010
2005 Nissan Sentra S 1.8L Hesitation, Surge, Cuts out, MIL Lamp on VIN: 3N1CB51D45
P0340: Camshaft Position Sensor Circuit Malfunction (Bank 1). I have seen maf sensor cause this on maximas and pathfinders. It bucks mostly when cold, but she says its starting to do it more after warm up.My snapon brick only goes to 04 so I am limitted on what I can see on this car. Called the dealer and they said no pr...
February 12, 2010
2003 Nissan Sentra GXE 1.8L Poor Idle Quality, Hesitation, Cuts out, Stall, Misfire VIN: 3N1CB51D53
P0340: Camshaft Position Sensor Circuit Malfunction. Sorry all! Posted this vehicle as fixed. Old ECU had signs of water intrusion with whitish deposits on cover and inside on and around circuit board. Replaced with new from dealer, ran fine. Parked vehicle. Same old puttering during warm up, will not rev over 2...
February 15, 2010
1996 Dodge Intrepid 3.3L No Start VIN: 2B3HD46T4T
P0340: No Camshaft Sensor Signals At PCM. this intrepid will start right up cold{0 to 10 degrees} when warming up will shut off suddenly,when warm in shop will never start.sets code for cam sensor when dies.replaced sensor no help.cam and crank have refrence power and ground.when trying to start scann...
February 18, 2010
1997 Plymouth Voyager SE 3.3L No Start, MIL Lamp on VIN: 1B4GP45R5V
P0340: No Camshaft Sensor Signals At PCM. Gentlemen, Van towed in , has good fuel pressure and the asd circuit working properly, has spark to 2/5 coil 3 times then dissapears ,1 spark from 1/4 coil and none from3/6 coil I can tell this 3 ways, from the driver wires at the coil , from the spark plugs a...
February 18, 2010
1997 Plymouth Voyager SE 3.3L No Start, MIL Lamp on VIN: 1B4GP45R5V
P0340: No Camshaft Sensor Signals At PCM. Gentlemen, Van towed in , has good fuel pressure and the asd circuit working properly, has spark to 2/5 coil 3 times then dissapears ,1 spark from 1/4 coil and none from3/6 coil I can tell this 3 ways, from the driver wires at the coil , from the spark plugs a...
February 19, 2010
1999 Land Rover Discovery SD 4.0L No Start VIN: SALTY1242X
im not getting a ground signal from the ecm for the main relay is this a common problem with this vehicle and when this happens my cooling fan willnot shut off (like bad ecm)
February 22, 2010
2002 Dodge Ram 1500 Van 3.9L Poor Idle Quality, MIL Lamp on VIN: 2B6HB11XX2
P0340: No Camshaft Sensor Signals At PCM. The customer has been driving the van since replacing the sensor with only a loss of power one time.Like I stated earlier I ohmed out the harness and it checks out OK and did a wiggle test and everything is also fine.I was wondering if anybody knows of any kno...
February 24, 2010