Join Now
International Automotive Technicians Network

P0340 Diagnostic Trouble Code Discussion for August 2009

CMP Sensor Circuit Malfunction


Note: This is a professional automotive technician's resource.
Vehicle Owners: If you are seeking an automotive repair professional to service your vehicle, visit the iATN Repair Shop Finder.

Trouble Ticket Help Requests for DTC P0340
Help Request Posted
2002 Chrysler Sebring LXi 2.7L MIL Lamp on VIN: 1C3EL56RX2
P0340: No Camshaft Sensor Signals At PCM. This vehicle came into our shop for P0340 No Cam Signal at PCM about six months ago. The first time in scandata was normal: cam, crank and sync. all present. Customer did complain about an intermittent stumble. Vehicle ran fine while at our shop. We scoped the...
August 11, 2009
2001 Mitsubishi Diamante ES 3.5L No Start VIN: 6MMAP67P0Y
P0340: Camshaft Position Sensor Circuit Malfunction. hi i have this mitsubishi diamante 3.5l coming back when wet out. dry when it was here and starting fine but resetting camshaft code po340 and crankshaft code po335. i dont have labscope but engine does seem to have a slight miss/rough idle. can wires or cap a...
August 11, 2009
2002 Ford F-150 King Ranch 5.4L Stall VIN: 1FTRW08L82
P0340: Loss of CMP Signal. ... Customer droped off his F-150 for a stall when comming to a stop, bucks and almost stalls on interstate driving, and CEL. All of these problems seam to occur when the engine is warm, driving for at least 30 min, and warm outside temp(at least70-75). Found ...
August 12, 2009
1997 BMW 528i 2.8L MIL Lamp on VIN: WBADD6327V
P0340: camshaft position a circuit. Hi all thanks for taking your time to help customer has no driveability complaints just check engine light is on so if any one has seen this problem I would greatly appreiate your help
August 13, 2009
1999 Chevrolet S10 LS 4.3L MIL Lamp on VIN: 1GTCT19W4X
P0340: CMP Sensor Circuit Malfunction. Please provide any suggestions- runs great, but no tach and MIL on for code PO340
August 13, 2009
2002 Ford F-150 King Ranch 5.4L Stall VIN: 1FTRW08L82
P0340: Loss of CMP Signal. ... Customer droped off his F-150 for a stall when comming to a stop, bucks and almost stalls on interstate driving, and CEL. All of these problems seam to occur when the engine is warm, driving for at least 30 min, and warm outside temp(at least70-75). Found ...
August 13, 2009
2002 Ford Mustang GT 4.6L Stall, MIL Lamp on VIN: 1FADP42X82
P0340: cmp fault. ... mil light appeares right away p0340.Preformed all ford pinpionts of the cmp to the point where it said to replace pcm. Replaced pcm problem still there. This is only on start up. I can clear codes It might start twice okay then on the third start it will s...
August 13, 2009
2002 Nissan Altima S 2.5L No Start VIN: 1NAL11D12C
P0340: Camshaft Position Sensor (Phase) Circuit Malfunction. Is it possible that we have a cam shaft /crankshaft synchronization problem? Could we be a tooth off on the crankshaft? Chain links/pins beteen the camshafts'gears were counted 26 links/pins and camshaft looks like it is in the right position according to the ...
August 13, 2009
2005 Chrysler PT Cruiser Classic 2.4L Cuts out, MIL Lamp on VIN: 3C4FY48B35
P0340: Camshaft Position Sensor Circuit Malfunction. ... replacement motor (43K on motor, same year) that keeps throwing CPS codes. The car ran great for a week of full time driving after engine replacement (about 250 miles) then threw a P0340 code for bad cam sensor and went into limp...
August 20, 2009
2006 Mazda 6 S 3.0L No Start VIN: 1YVHP80DX6
P0340: Camshaft Position Sensor Circuit Malfunction. This Mazda cranks fine, but the ignition only fires once each time I crank it. It also has a hard code for cam sensor bank one. I found in the archives older models with four cylinder engines with the same symptems. Those had timing chain problems, but I found...
August 22, 2009
2006 Mazda 6 S 3.0L No Start VIN: 1YVHP80DX6
P0340: Camshaft Position Sensor Circuit Malfunction. This Mazda cranks fine, but the ignition only fires once each time I crank it. It also has a hard code for cam sensor bank one. I found in the archives older models with four cylinder engines with the same symptems. Those had timing chain problems, but I found...
August 24, 2009
2002 Chrysler PT Cruiser Dream 2.4L No Start, MIL Lamp on VIN: 3C8FY68B12
P0340: Camshaft Position Sensor Circuit Malfunction. I am helping engine man with this one, Car came in no start. head gasket blown. He repaired. Would not start. He found crank sensor and connector melted. He replaced sensor and repaired connector. still no start. I checked and replaced with new connector, also...
August 31, 2009
2002 Chrysler Sebring LXi 2.7L MIL Lamp on VIN: 1C3EL56RX2
P0340: No Camshaft Sensor Signals At PCM. This vehicle came into our shop for P0340 No Cam Signal at PCM about six months ago. The first time in scandata was normal: cam, crank and sync. all present. Customer did complain about an intermittent stumble. Vehicle ran fine while at our shop. We scoped the...
August 11, 2009
2001 Mitsubishi Diamante ES 3.5L No Start VIN: 6MMAP67P0Y
P0340: Camshaft Position Sensor Circuit Malfunction. hi i have this mitsubishi diamante 3.5l coming back when wet out. dry when it was here and starting fine but resetting camshaft code po340 and crankshaft code po335. i dont have labscope but engine does seem to have a slight miss/rough idle. can wires or cap a...
August 11, 2009
2002 Ford F-150 King Ranch 5.4L Stall VIN: 1FTRW08L82
P0340: Loss of CMP Signal. ... Customer droped off his F-150 for a stall when comming to a stop, bucks and almost stalls on interstate driving, and CEL. All of these problems seam to occur when the engine is warm, driving for at least 30 min, and warm outside temp(at least70-75). Found ...
August 12, 2009
1997 BMW 528i 2.8L MIL Lamp on VIN: WBADD6327V
P0340: camshaft position a circuit. Hi all thanks for taking your time to help customer has no driveability complaints just check engine light is on so if any one has seen this problem I would greatly appreiate your help
August 13, 2009
1999 Chevrolet S10 LS 4.3L MIL Lamp on VIN: 1GTCT19W4X
P0340: CMP Sensor Circuit Malfunction. Please provide any suggestions- runs great, but no tach and MIL on for code PO340
August 13, 2009
2002 Ford F-150 King Ranch 5.4L Stall VIN: 1FTRW08L82
P0340: Loss of CMP Signal. ... Customer droped off his F-150 for a stall when comming to a stop, bucks and almost stalls on interstate driving, and CEL. All of these problems seam to occur when the engine is warm, driving for at least 30 min, and warm outside temp(at least70-75). Found ...
August 13, 2009
2002 Ford Mustang GT 4.6L Stall, MIL Lamp on VIN: 1FADP42X82
P0340: cmp fault. ... mil light appeares right away p0340.Preformed all ford pinpionts of the cmp to the point where it said to replace pcm. Replaced pcm problem still there. This is only on start up. I can clear codes It might start twice okay then on the third start it will s...
August 13, 2009
2002 Nissan Altima S 2.5L No Start VIN: 1NAL11D12C
P0340: Camshaft Position Sensor (Phase) Circuit Malfunction. Is it possible that we have a cam shaft /crankshaft synchronization problem? Could we be a tooth off on the crankshaft? Chain links/pins beteen the camshafts'gears were counted 26 links/pins and camshaft looks like it is in the right position according to the ...
August 13, 2009
2005 Chrysler PT Cruiser Classic 2.4L Cuts out, MIL Lamp on VIN: 3C4FY48B35
P0340: Camshaft Position Sensor Circuit Malfunction. ... replacement motor (43K on motor, same year) that keeps throwing CPS codes. The car ran great for a week of full time driving after engine replacement (about 250 miles) then threw a P0340 code for bad cam sensor and went into limp...
August 20, 2009
2006 Mazda 6 S 3.0L No Start VIN: 1YVHP80DX6
P0340: Camshaft Position Sensor Circuit Malfunction. This Mazda cranks fine, but the ignition only fires once each time I crank it. It also has a hard code for cam sensor bank one. I found in the archives older models with four cylinder engines with the same symptems. Those had timing chain problems, but I found...
August 22, 2009
2006 Mazda 6 S 3.0L No Start VIN: 1YVHP80DX6
P0340: Camshaft Position Sensor Circuit Malfunction. This Mazda cranks fine, but the ignition only fires once each time I crank it. It also has a hard code for cam sensor bank one. I found in the archives older models with four cylinder engines with the same symptems. Those had timing chain problems, but I found...
August 24, 2009
2002 Chrysler PT Cruiser Dream 2.4L No Start, MIL Lamp on VIN: 3C8FY68B12
P0340: Camshaft Position Sensor Circuit Malfunction. I am helping engine man with this one, Car came in no start. head gasket blown. He repaired. Would not start. He found crank sensor and connector melted. He replaced sensor and repaired connector. still no start. I checked and replaced with new connector, also...
August 31, 2009