Join Now
International Automotive Technicians Network

P0340 Diagnostic Trouble Code Discussion for July 2009

CMP Sensor Circuit Malfunction


Note: This is a professional automotive technician's resource.
Vehicle Owners: If you are seeking an automotive repair professional to service your vehicle, visit the iATN Repair Shop Finder.

Trouble Ticket Help Requests for DTC P0340
Help Request Posted
2006 Honda Accord EX 2.4L No Start, Stall, MIL Lamp on VIN: 1HGCM56736
P0340: Camshaft Position Sensor Circuit No Signal. ... may be able to give. ( sorry below is a little extensive ) 7-2-09 Received this vehicle back again this morning ( on back of Flatbed ) Customer complaint again, Stalled while driving. Will start after sitting for 45 min. or so Checked for codes and was...
July 02, 2009
1996 Ford Windstar GL 3.8L Poor Idle Quality, MIL Lamp on VIN: 2FMDA5144T
P0340: cam sensor circuit malfonction. this windstar run bad at idle and a p0340 is always on when we unplung the cam sensor it run fine ,another garage replaced the cam sensor and forgoted to repair a vacuum leak so after the vacuum was ok the van still run bad i chenged the cam synchro checked th...
July 08, 2009
2002 Mitsubishi Eclipse GS 2.4L MIL Lamp on VIN: 4A3AC44G02
P0340: Camshaft Position Sensor Circuit Malfunction. This vehicle was brought in to us by a used car dealer because it keeps throwing cmp and ckp sensor codes. The used car dealer replaced both sensors and checked the timing belt for alignment, which was ok. So now I have it. I am considering that possibly the e...
July 13, 2009
2002 Mitsubishi Eclipse GS 2.4L MIL Lamp on VIN: 4A3AC44G02
P0340: Camshaft Position Sensor Circuit Malfunction. This vehicle was brought in to us by a used car dealer because it keeps throwing cmp and ckp sensor codes. The used car dealer replaced both sensors and checked the timing belt for alignment, which was ok. So now I have it. I am considering that possibly the e...
July 14, 2009
2004 Nissan Sentra 1.8L No Start, MIL Lamp on
P0340: Camshaft Position Sensor Circuit Malfunction (Bank 1). Customer had towed in crank no start. Ethos showed cam sensor problem (replaced no change) Found weak spark on cyl 1 repaced coil on. no change. satisfied with fire moved on to fuel No schrader valve to check pressure with out cutting line but dissconected and...
July 15, 2009
1999 Jeep Grand Cherokee Laredo 4.0L Cuts out, Stall VIN: 1J4G258S3X
P0340: No Camshaft Sensor Signals At PCM. I've got a 99 Grand Cherokee 4.0 that was towed into my shop today. It starts up fine, runs fine for about 5 - 8 seconds and then like clockwork, it drops injector pulse. It has coil on plug so it's hard to check spark but I am able to keep it running with car...
July 22, 2009
2002 Mitsubishi Montero Limited 3.5L No Start VIN: JA4MW51R72
P0340: Camshaft Position Sensor Circuit Malfunction. ... start,checked all the basics,checked for chewed wires,keeps setting cam and crank codes po335,and p0340,both sensors have 12v,ground,and 5v reference.i dont have acess to the lab scope.i checked for aac voltage while crank...
July 22, 2009
2002 Nissan Altima 2.5L MIL Lamp on, NO START SOMETIMES VIN: 1N4AL1D32C
P0340: Camshaft Position Sensor (Phase) Circuit Malfunction. will start & run sometimes. had code po340. installed cps sensor kit & still having same problem.
July 23, 2009
2002 Kia Spectra 1.8L Poor Idle Quality, Misfire, MIL Lamp on VIN: KNAFB12142
P0340: Camshaft Position Sensor Circuit Malfunction. ... been redone, has new timing belt, new cam sensor, one new coil, new spark plugs, new plug wires, all before it got to me. It is sporting two codes P0340 Cam Sensor Malfunction, and a P0300 multiple cylinder misfire, in t...
July 27, 2009
1996 Ford F Super Duty XL 7.3L Surge, Misfire VIN: 1FDLF47FTE
P0340: Camshaft Position Sensor Circuit Malfunction. vech came in would not accelerate with out cutting out and setting cam sensor code. Put old cam sensor had in it and ran fine. Replaced cam sensor with updated cam sensor vech will barely run used 3 different updated sensors and will not run put old style sens...
July 30, 2009
2006 Honda Accord EX 2.4L No Start, Stall, MIL Lamp on VIN: 1HGCM56736
P0340: Camshaft Position Sensor Circuit No Signal. ... may be able to give. ( sorry below is a little extensive ) 7-2-09 Received this vehicle back again this morning ( on back of Flatbed ) Customer complaint again, Stalled while driving. Will start after sitting for 45 min. or so Checked for codes and was...
July 02, 2009
1996 Ford Windstar GL 3.8L Poor Idle Quality, MIL Lamp on VIN: 2FMDA5144T
P0340: cam sensor circuit malfonction. this windstar run bad at idle and a p0340 is always on when we unplung the cam sensor it run fine ,another garage replaced the cam sensor and forgoted to repair a vacuum leak so after the vacuum was ok the van still run bad i chenged the cam synchro checked th...
July 08, 2009
2002 Mitsubishi Eclipse GS 2.4L MIL Lamp on VIN: 4A3AC44G02
P0340: Camshaft Position Sensor Circuit Malfunction. This vehicle was brought in to us by a used car dealer because it keeps throwing cmp and ckp sensor codes. The used car dealer replaced both sensors and checked the timing belt for alignment, which was ok. So now I have it. I am considering that possibly the e...
July 13, 2009
2002 Mitsubishi Eclipse GS 2.4L MIL Lamp on VIN: 4A3AC44G02
P0340: Camshaft Position Sensor Circuit Malfunction. This vehicle was brought in to us by a used car dealer because it keeps throwing cmp and ckp sensor codes. The used car dealer replaced both sensors and checked the timing belt for alignment, which was ok. So now I have it. I am considering that possibly the e...
July 14, 2009
2004 Nissan Sentra 1.8L No Start, MIL Lamp on
P0340: Camshaft Position Sensor Circuit Malfunction (Bank 1). Customer had towed in crank no start. Ethos showed cam sensor problem (replaced no change) Found weak spark on cyl 1 repaced coil on. no change. satisfied with fire moved on to fuel No schrader valve to check pressure with out cutting line but dissconected and...
July 15, 2009
1999 Jeep Grand Cherokee Laredo 4.0L Cuts out, Stall VIN: 1J4G258S3X
P0340: No Camshaft Sensor Signals At PCM. I've got a 99 Grand Cherokee 4.0 that was towed into my shop today. It starts up fine, runs fine for about 5 - 8 seconds and then like clockwork, it drops injector pulse. It has coil on plug so it's hard to check spark but I am able to keep it running with car...
July 22, 2009
2002 Mitsubishi Montero Limited 3.5L No Start VIN: JA4MW51R72
P0340: Camshaft Position Sensor Circuit Malfunction. ... start,checked all the basics,checked for chewed wires,keeps setting cam and crank codes po335,and p0340,both sensors have 12v,ground,and 5v reference.i dont have acess to the lab scope.i checked for aac voltage while crank...
July 22, 2009
2002 Nissan Altima 2.5L MIL Lamp on, NO START SOMETIMES VIN: 1N4AL1D32C
P0340: Camshaft Position Sensor (Phase) Circuit Malfunction. will start & run sometimes. had code po340. installed cps sensor kit & still having same problem.
July 23, 2009
2002 Kia Spectra 1.8L Poor Idle Quality, Misfire, MIL Lamp on VIN: KNAFB12142
P0340: Camshaft Position Sensor Circuit Malfunction. ... been redone, has new timing belt, new cam sensor, one new coil, new spark plugs, new plug wires, all before it got to me. It is sporting two codes P0340 Cam Sensor Malfunction, and a P0300 multiple cylinder misfire, in t...
July 27, 2009
1996 Ford F Super Duty XL 7.3L Surge, Misfire VIN: 1FDLF47FTE
P0340: Camshaft Position Sensor Circuit Malfunction. vech came in would not accelerate with out cutting out and setting cam sensor code. Put old cam sensor had in it and ran fine. Replaced cam sensor with updated cam sensor vech will barely run used 3 different updated sensors and will not run put old style sens...
July 30, 2009