Join Now
International Automotive Technicians Network

P0340 Diagnostic Trouble Code Discussion for February 2009

CMP Sensor Circuit Malfunction


Note: This is a professional automotive technician's resource.
Vehicle Owners: If you are seeking an automotive repair professional to service your vehicle, visit the iATN Repair Shop Finder.

Trouble Ticket Help Requests for DTC P0340
Help Request Posted
2003 Ford Mustang GT 4.6L No Start, MIL Lamp on VIN: 1FAFP45X63
P0340: Cam Position Sensor. ... was intermitent no start, cycle key and vehicle would start. Service engine light on. SEEMS LIKE THE TIMING IS OFF WHEN THE PROBLEM OCCURS. I know the cam affects the timing of the individual coils. We pulled codes(p0340 Cam Sensor) It's a magnetic style n...
February 03, 2009
1998 BMW 528i 2.8L Hesitation, MIL Lamp on VIN: WBADD6327-
P0340: cam sensor. ... got... Im working on a 98 528i, came in originally with a MIL on, code p0340, cam sensor. Found cam sensor pigtail insulation crumbling, replaced cam sensor w/ a siemens/vdo unit, cleared code, test drove, all was fine for a month. Car came back in, same c...
February 05, 2009
2005 Dodge Ram 1500 Truck ST 5.7L Poor Idle Quality, MIL Lamp on, Intmt hard start VIN: 1D7HV18035
P0340: Camshaft Position Sensor Circuit Malfunction. Customer advises vehicle has no throttle control. Vehicle will start and run normally for about 3-5 minutes, after which time it will lose throttle control. Attempts to restart result in extended crank time, & rough idle followed by MIL & flashing ETC ...
February 05, 2009
2004 Chrysler PT Cruiser Touring 2.4L Surge, MIL Lamp on VIN: 3C4FY58B94
P0340: Camshaft Position Sensor Circuit Malfunction. Hi everyone . need some info on this pt , i have a code PO340 that will set on a road test and when it set the vehicle will surge at anything over 2300 rpm - fells like rev limiter kicking in -you can clear code and it will run perfectly for 5 to 15 miles befo...
February 10, 2009
1999 Mazda 626 ES 2.0L MIL Lamp on VIN: 1YVGF22C8X
P0340: Camshaft Position Sensor Circuit Malfunction. ... smog test and failed due to code P0340 camshaft position sensor fault. The wires for the sensor looked like they had been caught up in the belt which would indicate an obvious problem. I have repaired the wiring and ohm tested .5 ohm from sensor to PCM. No...
February 11, 2009
1999 Chevrolet K1500 Suburban 5.7L Poor Idle Quality, Hesitation, Surge, Cuts out, MIL Lamp on VIN: 1GKFK16R1X
P0340: CMP Sensor Circuit Malfunction. ... to read and respond to this one. This Surburban is giving me a major headache! Customer tuned it up himself and replaced the listed parts. Came to me running rough, checked cap and rotor and found rotor loose, fixed that and replaced the cap. Reset cam sy...
February 12, 2009
2004 Kia Optima LX 2.4L MIL Lamp on VIN: KNAGD12674
P0340: Camshaft Position Sensor Circuit Malfunction. ... home next morning would start up and it would die after 10 to 15 seconds of running you could give gas and engine rpm would go up but still die have check cam amd crank sensor ref to pcm all checks good and the p0340 code keeps coming back after cleared af...
February 16, 2009
1997 Toyota Camry CE 2.2L MIL Lamp on VIN: JT2BG22K2V
P0340: Camshaft Position Sensor Circuit Malfunction. found the cam sensor & bracket tucked away behind the coolant hoses on the passanger side of the engine. not sure where it goes on the head or timing cover ? looks like it may have been off for a while very dirty. alldata has a picture but did not see moun...
February 18, 2009
1998 Ford Windstar GL 3.8L Cuts out, Misfire VIN: 2FMZA5145W
P0340: cam position sensor circuit fault. Code P0340 is stored. We replaced the cam position sensor with no change. Tried setting the cam synchro in the proper postiton with special line up tool and with lab scope. Code keeps coming back. Has anybody else run into this problem. Plugs and wires were re...
February 19, 2009
1999 Chevrolet K1500 Suburban 5.7L Poor Idle Quality, Hesitation, Surge, Cuts out, MIL Lamp on VIN: 1GKFK16R1X
P0340: CMP Sensor Circuit Malfunction. ... to read and respond to this one. This Surburban is giving me a major headache! Customer tuned it up himself and replaced the listed parts. Came to me running rough, checked cap and rotor and found rotor loose, fixed that and replaced the cap. Reset cam sy...
February 23, 2009
2004 Ford Taurus SES 3.0L MIL Lamp on VIN: 1FAFP55274
P0340: cam sensor sygnal problem. ... week with a no start,customer stated that it had a trans rebuilt just recently,we scanned the computer and got a code for engine temp sensor replaced that still no start had good fuel pressure and spark ok too,so I checked the Cam sensor and there was no s...
February 24, 2009
2003 Ford Mustang GT 4.6L No Start, MIL Lamp on VIN: 1FAFP45X63
P0340: Cam Position Sensor. ... was intermitent no start, cycle key and vehicle would start. Service engine light on. SEEMS LIKE THE TIMING IS OFF WHEN THE PROBLEM OCCURS. I know the cam affects the timing of the individual coils. We pulled codes(p0340 Cam Sensor) It's a magnetic style n...
February 03, 2009
1998 BMW 528i 2.8L Hesitation, MIL Lamp on VIN: WBADD6327-
P0340: cam sensor. ... got... Im working on a 98 528i, came in originally with a MIL on, code p0340, cam sensor. Found cam sensor pigtail insulation crumbling, replaced cam sensor w/ a siemens/vdo unit, cleared code, test drove, all was fine for a month. Car came back in, same c...
February 05, 2009
2005 Dodge Ram 1500 Truck ST 5.7L Poor Idle Quality, MIL Lamp on, Intmt hard start VIN: 1D7HV18035
P0340: Camshaft Position Sensor Circuit Malfunction. Customer advises vehicle has no throttle control. Vehicle will start and run normally for about 3-5 minutes, after which time it will lose throttle control. Attempts to restart result in extended crank time, & rough idle followed by MIL & flashing ETC ...
February 05, 2009
2004 Chrysler PT Cruiser Touring 2.4L Surge, MIL Lamp on VIN: 3C4FY58B94
P0340: Camshaft Position Sensor Circuit Malfunction. Hi everyone . need some info on this pt , i have a code PO340 that will set on a road test and when it set the vehicle will surge at anything over 2300 rpm - fells like rev limiter kicking in -you can clear code and it will run perfectly for 5 to 15 miles befo...
February 10, 2009
1999 Mazda 626 ES 2.0L MIL Lamp on VIN: 1YVGF22C8X
P0340: Camshaft Position Sensor Circuit Malfunction. ... smog test and failed due to code P0340 camshaft position sensor fault. The wires for the sensor looked like they had been caught up in the belt which would indicate an obvious problem. I have repaired the wiring and ohm tested .5 ohm from sensor to PCM. No...
February 11, 2009
1999 Chevrolet K1500 Suburban 5.7L Poor Idle Quality, Hesitation, Surge, Cuts out, MIL Lamp on VIN: 1GKFK16R1X
P0340: CMP Sensor Circuit Malfunction. ... to read and respond to this one. This Surburban is giving me a major headache! Customer tuned it up himself and replaced the listed parts. Came to me running rough, checked cap and rotor and found rotor loose, fixed that and replaced the cap. Reset cam sy...
February 12, 2009
2004 Kia Optima LX 2.4L MIL Lamp on VIN: KNAGD12674
P0340: Camshaft Position Sensor Circuit Malfunction. ... home next morning would start up and it would die after 10 to 15 seconds of running you could give gas and engine rpm would go up but still die have check cam amd crank sensor ref to pcm all checks good and the p0340 code keeps coming back after cleared af...
February 16, 2009
1997 Toyota Camry CE 2.2L MIL Lamp on VIN: JT2BG22K2V
P0340: Camshaft Position Sensor Circuit Malfunction. found the cam sensor & bracket tucked away behind the coolant hoses on the passanger side of the engine. not sure where it goes on the head or timing cover ? looks like it may have been off for a while very dirty. alldata has a picture but did not see moun...
February 18, 2009
1998 Ford Windstar GL 3.8L Cuts out, Misfire VIN: 2FMZA5145W
P0340: cam position sensor circuit fault. Code P0340 is stored. We replaced the cam position sensor with no change. Tried setting the cam synchro in the proper postiton with special line up tool and with lab scope. Code keeps coming back. Has anybody else run into this problem. Plugs and wires were re...
February 19, 2009
1999 Chevrolet K1500 Suburban 5.7L Poor Idle Quality, Hesitation, Surge, Cuts out, MIL Lamp on VIN: 1GKFK16R1X
P0340: CMP Sensor Circuit Malfunction. ... to read and respond to this one. This Surburban is giving me a major headache! Customer tuned it up himself and replaced the listed parts. Came to me running rough, checked cap and rotor and found rotor loose, fixed that and replaced the cap. Reset cam sy...
February 23, 2009
2004 Ford Taurus SES 3.0L MIL Lamp on VIN: 1FAFP55274
P0340: cam sensor sygnal problem. ... week with a no start,customer stated that it had a trans rebuilt just recently,we scanned the computer and got a code for engine temp sensor replaced that still no start had good fuel pressure and spark ok too,so I checked the Cam sensor and there was no s...
February 24, 2009