Join Now
International Automotive Technicians Network

P0340 Diagnostic Trouble Code Discussion for December 2007

CMP Sensor Circuit Malfunction


Note: This is a professional automotive technician's resource.
Vehicle Owners: If you are seeking an automotive repair professional to service your vehicle, visit the iATN Repair Shop Finder.

Trouble Ticket Help Requests for DTC P0340
Help Request Posted
1997 BMW 740i 4.4L MIL Lamp on VIN: WBAGF8325V
P0340: camshaft postion sensor. ... shop running poorly with MIL on with code P0340. Knowing that there is a problem with these cam sensors, we replaced it with a factory part. This took care of the drivabilty problem and car runs great BUT, on the second key cycle P0340 resets still no driv...
December 04, 2007
2003 Mitsubishi Galant ES 2.4L MIL Lamp on VIN: 4A3AA46G13
P0340: Camshaft Position Sensor Circuit Malfunction. Sets both P0335 & p0340 while starting, but not every time. I can clear the codes and if the codes do not set while starting, the car can be driven without any codes being reset. The light will come on right after cranking up hot or cold, used the vantage ...
December 05, 2007
1996 Chrysler Town & Country (Van) 3.3L Poor Idle Quality, Hesitation, Surge, Cuts out, Misfire, MIL Lamp on VIN: 1C4GP54R8T
P0340: no cam signal at pcm. First of all thanks to all who help from the beginning. This van has been here for about two or three months but whose counting. This van came in stumbling and popping back through the intake. It keeps setting a cam, crank code and loss of cam signal. This is ...
December 06, 2007
2003 Mitsubishi Galant ES 2.4L MIL Lamp on VIN: 4A3AA46G13
P0340: Camshaft Position Sensor Circuit Malfunction. Sets both P0335 & p0340 while starting, but not every time. I can clear the codes and if the codes do not set while starting, the car can be driven without any codes being reset. The light will come on right after cranking up hot or cold, used the vantage ...
December 07, 2007
2000 Ford F-150 XL 4.2L Cuts out, MIL Lamp on VIN: 1FTZX1722Y
P0340: Cam Sensor Circuit. Guys, I have a problem child. It sets the code on every start. Replace Cam Sensor, no change. After data base I disconnected dpfe sensor & plug on Alt, no change. One strange thing is customer stated on cold start up it makes a chirping noise. This morning...
December 10, 2007
2000 Mercury Mountaineer 5.0L Poor Idle Quality, Hesitation, Surge, Misfire, MIL Lamp on VIN: 4M2ZU86P0Y
P0340: Camshaft position sensor circuit malfunction. ... mil on and a rolling idle. scan test found the P0340 cam sensor code. Hooked up break out box and scoped cam signal. Found signal to be erratic and negative amplitude to be non-existent. Replaced cam sensor and synchronizer with one from Ford. Still set P0...
December 13, 2007
2002 Nissan Altima 2.5L No Start, Stall, MIL Lamp on VIN: 1N4AL11DO2
P0340: Camshaft Position Sensor (Phase) Circuit Malfunction. Hi folks, there seems to be some discrepencies at nissan about these cmp & ckp sensors, after 4 of them I figured I would move on. Mine is like several others I've read about, tow in no start. PO340 is present,no tach , but rpm on modis is ok, start signal...
December 13, 2007
2004 Ford Explorer Eddie Bauer 4.6L Poor Idle Quality, MIL Lamp on VIN: 1FMZU64W44
P0340: Cam sensor. ... for a friend of ours. He has an 04 Explorer with a 4.6 and storing a P0340 (Cam Sensor Signal) on startup. The information I am recording is second hand so the details are not as good as we would wish. He does not have a scope. The "sync" pid rea...
December 19, 2007
1995 Ford Windstar GL 3.8L MIL Lamp on VIN: 2FMDA5141S
P0340: Cam Position Sensor Circiut Fault. wave form on the CMP and Crank Sensor look good.grounds checked good.wiring checks good.Dual trace lab scope shows CMP at 26 degrees. Will one degree make a difference on the CMP?
December 20, 2007
2004 Ford Explorer Eddie Bauer 4.6L Poor Idle Quality, MIL Lamp on VIN: 1FMZU64W44
P0340: Cam sensor. ... for a friend of ours. He has an 04 Explorer with a 4.6 and storing a P0340 (Cam Sensor Signal) on startup. The information I am recording is second hand so the details are not as good as we would wish. He does not have a scope. The "sync" pid rea...
December 20, 2007
1997 BMW 740i 4.4L MIL Lamp on VIN: WBAGF8325V
P0340: camshaft postion sensor. ... shop running poorly with MIL on with code P0340. Knowing that there is a problem with these cam sensors, we replaced it with a factory part. This took care of the drivabilty problem and car runs great BUT, on the second key cycle P0340 resets still no driv...
December 04, 2007
2003 Mitsubishi Galant ES 2.4L MIL Lamp on VIN: 4A3AA46G13
P0340: Camshaft Position Sensor Circuit Malfunction. Sets both P0335 & p0340 while starting, but not every time. I can clear the codes and if the codes do not set while starting, the car can be driven without any codes being reset. The light will come on right after cranking up hot or cold, used the vantage ...
December 05, 2007
1996 Chrysler Town & Country (Van) 3.3L Poor Idle Quality, Hesitation, Surge, Cuts out, Misfire, MIL Lamp on VIN: 1C4GP54R8T
P0340: no cam signal at pcm. First of all thanks to all who help from the beginning. This van has been here for about two or three months but whose counting. This van came in stumbling and popping back through the intake. It keeps setting a cam, crank code and loss of cam signal. This is ...
December 06, 2007
2003 Mitsubishi Galant ES 2.4L MIL Lamp on VIN: 4A3AA46G13
P0340: Camshaft Position Sensor Circuit Malfunction. Sets both P0335 & p0340 while starting, but not every time. I can clear the codes and if the codes do not set while starting, the car can be driven without any codes being reset. The light will come on right after cranking up hot or cold, used the vantage ...
December 07, 2007
2000 Ford F-150 XL 4.2L Cuts out, MIL Lamp on VIN: 1FTZX1722Y
P0340: Cam Sensor Circuit. Guys, I have a problem child. It sets the code on every start. Replace Cam Sensor, no change. After data base I disconnected dpfe sensor & plug on Alt, no change. One strange thing is customer stated on cold start up it makes a chirping noise. This morning...
December 10, 2007
2000 Mercury Mountaineer 5.0L Poor Idle Quality, Hesitation, Surge, Misfire, MIL Lamp on VIN: 4M2ZU86P0Y
P0340: Camshaft position sensor circuit malfunction. ... mil on and a rolling idle. scan test found the P0340 cam sensor code. Hooked up break out box and scoped cam signal. Found signal to be erratic and negative amplitude to be non-existent. Replaced cam sensor and synchronizer with one from Ford. Still set P0...
December 13, 2007
2002 Nissan Altima 2.5L No Start, Stall, MIL Lamp on VIN: 1N4AL11DO2
P0340: Camshaft Position Sensor (Phase) Circuit Malfunction. Hi folks, there seems to be some discrepencies at nissan about these cmp & ckp sensors, after 4 of them I figured I would move on. Mine is like several others I've read about, tow in no start. PO340 is present,no tach , but rpm on modis is ok, start signal...
December 13, 2007
2004 Ford Explorer Eddie Bauer 4.6L Poor Idle Quality, MIL Lamp on VIN: 1FMZU64W44
P0340: Cam sensor. ... for a friend of ours. He has an 04 Explorer with a 4.6 and storing a P0340 (Cam Sensor Signal) on startup. The information I am recording is second hand so the details are not as good as we would wish. He does not have a scope. The "sync" pid rea...
December 19, 2007
1995 Ford Windstar GL 3.8L MIL Lamp on VIN: 2FMDA5141S
P0340: Cam Position Sensor Circiut Fault. wave form on the CMP and Crank Sensor look good.grounds checked good.wiring checks good.Dual trace lab scope shows CMP at 26 degrees. Will one degree make a difference on the CMP?
December 20, 2007
2004 Ford Explorer Eddie Bauer 4.6L Poor Idle Quality, MIL Lamp on VIN: 1FMZU64W44
P0340: Cam sensor. ... for a friend of ours. He has an 04 Explorer with a 4.6 and storing a P0340 (Cam Sensor Signal) on startup. The information I am recording is second hand so the details are not as good as we would wish. He does not have a scope. The "sync" pid rea...
December 20, 2007