Join Now
International Automotive Technicians Network

P0341 Diagnostic Trouble Code Discussion for November 2007

CMP Sensor Performance


Note: This is a professional automotive technician's resource.
Vehicle Owners: If you are seeking an automotive repair professional to service your vehicle, visit the iATN Repair Shop Finder.

Trouble Ticket Help Requests for DTC P0341
Help Request Posted
1998 Subaru Forester L 2.5L Poor Idle Quality, Cuts out, Poor Fuel Economy, MIL Lamp on VIN: JF1SF6359W
P0341: Camshaft Position Sensor Range/Performance. ... to drive me over the deep end. The lady is from out of town, came in with a check engine light and running poorly when warmed. The vehicle had just had plugs, fuel filter, and LOF right before she left home (Portland) and headed this way (about 275 miles) ...
November 01, 2007
2002 Isuzu Rodeo S 2.2L No Power VIN: 4S2CK58D82
P0341: Camshaft Position Sensor Range/Performance. ... Rodeo has little power. It originally came in for no power and overheating. The head gasket was leaking, and the customer was going to let his friend repair. So I looking at it now with the overheating problem taken care of, and still little power. After ...
November 03, 2007
2002 Isuzu Rodeo S 2.2L No Power VIN: 4S2CK58D82
P0341: Camshaft Position Sensor Range/Performance. ... Rodeo has little power. It originally came in for no power and overheating. The head gasket was leaking, and the customer was going to let his friend repair. So I looking at it now with the overheating problem taken care of, and still little power. After ...
November 08, 2007
1996 Chevrolet K2500 Suburban LS 7.4L Poor Idle Quality, Hesitation, Surge, Cuts out, Stall, MIL Lamp on VIN: 3GNGK26J4T
P0341: CMP Sensor Performance. good evening to all.i dont know where to start but i dont understand the cam numbers and i need help. this suburban cam back with a bad surge at idle,almost as if the key was being turned of then back on.the cam retard was going as high as 30 then may drop as ...
November 13, 2007
2000 Pontiac Grand Am SE 3.4L Cuts out, Stall
P0341: CMP Sensor Performance. Hey Guys and Gals, Got a cam sensor code on a 3.4 and haven't seen this before, performed the trouble tree from GM for the code and fixed 3 bad spark plug wires but the sensor seemed to be working OK. I looked at the tech 2 and had Cam sensor signal present. T...
November 15, 2007