Join Now
International Automotive Technicians Network

P0340 Diagnostic Trouble Code Discussion for December 2006

CMP Sensor Circuit Malfunction


Note: This is a professional automotive technician's resource.
Vehicle Owners: If you are seeking an automotive repair professional to service your vehicle, visit the iATN Repair Shop Finder.

Trouble Ticket Help Requests for DTC P0340
Help Request Posted
2000 Ford Explorer XLS 4.0L MIL Lamp on VIN: 1FMDU72X6Y
P0340: camshaft sensor. This has been a problem child for a while now. We rebuilt the engine on this explorer. Shortly after job left, the engine light came on for camshaft sensor fault. We removed syncro and reset with install tool. We kept vehicle and light came back on two days la...
December 06, 2006
2005 Ford F-250 Super Duty Lariat 5.4L MIL Lamp on VIN: 1FTNX20525
P0340: Camshaft Position Sensor Circuit Malfunction. We originally received this truck in a no run condition. After many hours of diagnosing we discovered that the bank 2 cam shaft and cam gear had apparently been loose and the key way had layed over and allowed bank 2 cam timing to change and was creating our n...
December 11, 2006
2003 Chrysler PT Cruiser GT 2.4L Surge, MIL Lamp on VIN: 3C8FY78G03
P0340: Camshaft Position Sensor Circuit Malfunction. ... shop with a check engine light on and code p0340. I have cleared the code and it comes back after about 50 miles. I have looked at all the conections and have found nothing abnormal. This started after cust. became stuck in some snow. I have contacted our ...
December 12, 2006
1999 Subaru Legacy Limited 30th Anniversary 2.5L Excessive Emissions, Poor Idle Quality, Hesitation, Misfire, MIL Lamp on VIN: 4S3BG6851X
P0340: Camshaft Position Sensor Circuit Malfunction. Sorry for the long post, but we've been 'round and 'round with this one and are out of ideas. Car ran good with used engine for about 5 K miles. Symptoms are it runs good cold, but when it gets to operating temp it starts to run rich, idle rough and blows blac...
December 14, 2006
2002 Jeep Grand Cherokee Laredo 4.7L No Start, Stall, MIL Lamp on VIN: 1J8GW48N52
P0340: No Camshaft Sensor Signals At PCM. hello, when cold it will start/run for a min. start to sputter, set code po320 & po340 will stall then start several times before it finally wont start. we checked waveform on lab scope and found cam sensor is faulty. however when vehicle quits the asd re...
December 20, 2006
2000 Ford Explorer XLS 4.0L MIL Lamp on VIN: 1FMDU72X6Y
P0340: camshaft sensor. This has been a problem child for a while now. We rebuilt the engine on this explorer. Shortly after job left, the engine light came on for camshaft sensor fault. We removed syncro and reset with install tool. We kept vehicle and light came back on two days la...
December 06, 2006
2005 Ford F-250 Super Duty Lariat 5.4L MIL Lamp on VIN: 1FTNX20525
P0340: Camshaft Position Sensor Circuit Malfunction. We originally received this truck in a no run condition. After many hours of diagnosing we discovered that the bank 2 cam shaft and cam gear had apparently been loose and the key way had layed over and allowed bank 2 cam timing to change and was creating our n...
December 11, 2006
2003 Chrysler PT Cruiser GT 2.4L Surge, MIL Lamp on VIN: 3C8FY78G03
P0340: Camshaft Position Sensor Circuit Malfunction. ... shop with a check engine light on and code p0340. I have cleared the code and it comes back after about 50 miles. I have looked at all the conections and have found nothing abnormal. This started after cust. became stuck in some snow. I have contacted our ...
December 12, 2006
1999 Subaru Legacy Limited 30th Anniversary 2.5L Excessive Emissions, Poor Idle Quality, Hesitation, Misfire, MIL Lamp on VIN: 4S3BG6851X
P0340: Camshaft Position Sensor Circuit Malfunction. Sorry for the long post, but we've been 'round and 'round with this one and are out of ideas. Car ran good with used engine for about 5 K miles. Symptoms are it runs good cold, but when it gets to operating temp it starts to run rich, idle rough and blows blac...
December 14, 2006
2002 Jeep Grand Cherokee Laredo 4.7L No Start, Stall, MIL Lamp on VIN: 1J8GW48N52
P0340: No Camshaft Sensor Signals At PCM. hello, when cold it will start/run for a min. start to sputter, set code po320 & po340 will stall then start several times before it finally wont start. we checked waveform on lab scope and found cam sensor is faulty. however when vehicle quits the asd re...
December 20, 2006