Join Now
International Automotive Technicians Network

P0340 Diagnostic Trouble Code Discussion for September 2005

CMP Sensor Circuit Malfunction


Note: This is a professional automotive technician's resource.
Vehicle Owners: If you are seeking an automotive repair professional to service your vehicle, visit the iATN Repair Shop Finder.

Trouble Ticket Help Requests for DTC P0340
Help Request Posted
1996 Ford Windstar GL 3.8L Hesitation, Misfire VIN: 2FMDA5145T
P0340: Camshaft sensor code. ... under accelaration which explains the P0300. The vehicle has new plugs and wires on it. We also have a cam sensor code P0340. The cam sensor and drive housing was replaced about 6 months / 4000 miles ago and it ran fine after its replacement. We rechecked ...
September 06, 2005
1999 Ford Windstar LX 3.8L Stall, vehicle dies VIN: 2FMDA5145X
P0340: replaced cam sensor. The vehicle dies when under a slight load, while turning or moving up a small incline. When put under a load the idle goes down everytime, but when the IAC motor electrical connection is unplugged, the engine loses idle capability, indicating the IAC works, co...
September 12, 2005
2000 Ford E-150 Econoline 4.2L Hesitation, MIL Lamp on VIN: 1FTRE1422Y
P0340: cam sensor. well after initial shooting of the p0340 code and changing related items of each dead end i looked here and found a couple more ideas with more parts and still no change. the van idles fine, bout 1/4 throttle in park it will studder and stumble. little more th...
September 12, 2005
2001 Ford Focus LX 2.0L MIL Lamp on VIN: 1FAFP33P31
P0340: cam sensor error. I was made aware of this car after a routine oil change in our shop with the proper oil 5w20. Car returned with SES light on found code PO340. Tech thought car was running fine and cleared code. Car returned two weeks later same code. Checked with ossiloscope ...
September 17, 2005
1995 Nissan Maxima GLE 3.0L Misfire VIN: JN1CA21D1S
P0340: cam position sensor. This is an interesting one. This vehicle came to us from our sister shop across town. They had replaced the components listed below and gave up. Cylinders 2 and 3 have a dead miss and the coils for those cylinders are not receiving a signal to fire from the EC...
September 22, 2005
2000 Oldsmobile Bravada 4.3L Hesitation, MIL Lamp on VIN: 1GHDT13W7Y
P0340: CMP Sensor Circuit Malfunction. ... gauge, stuck in middle. grounded circuit and the gauge pegs. told customer it was the sending unit. she returned the next day saying her check engine light came on after leaving shop. checked codes and got codes p0102 mass air flow sensor voltage too low, ...
September 27, 2005
2004 Chrysler Sebring 2.7L Surge, Cuts out, MIL Lamp on VIN: 1C3EL46R84
P0340: No Camshaft Sensor Signals At PCM. sos to all crysler techs this car is the car from hell , our local boneyard that lets us grab what we need when we need it dropped this bomber on us they got it as a total after a front end wreck that broke clyinder head at cam gear they put a motor from a 03 ...
September 29, 2005
2000 Jeep Cherokee Sport 4.0L MIL Lamp on VIN: 1J4FT48S7Y
P0340: No Camshaft Sensor Signals At PCM. Customer states that he has an intermittent hard start (long cranking with occasional popping noise) in the A.M. for months. The CEL was on with two codes when arrived and cam and crank sensors check out, wave forms appear normal. All wiring and connectors loo...
September 30, 2005
1996 Ford Windstar GL 3.8L Hesitation, Misfire VIN: 2FMDA5145T
P0340: Camshaft sensor code. ... under accelaration which explains the P0300. The vehicle has new plugs and wires on it. We also have a cam sensor code P0340. The cam sensor and drive housing was replaced about 6 months / 4000 miles ago and it ran fine after its replacement. We rechecked ...
September 06, 2005
1999 Ford Windstar LX 3.8L Stall, vehicle dies VIN: 2FMDA5145X
P0340: replaced cam sensor. The vehicle dies when under a slight load, while turning or moving up a small incline. When put under a load the idle goes down everytime, but when the IAC motor electrical connection is unplugged, the engine loses idle capability, indicating the IAC works, co...
September 12, 2005
2000 Ford E-150 Econoline 4.2L Hesitation, MIL Lamp on VIN: 1FTRE1422Y
P0340: cam sensor. well after initial shooting of the p0340 code and changing related items of each dead end i looked here and found a couple more ideas with more parts and still no change. the van idles fine, bout 1/4 throttle in park it will studder and stumble. little more th...
September 12, 2005
2001 Ford Focus LX 2.0L MIL Lamp on VIN: 1FAFP33P31
P0340: cam sensor error. I was made aware of this car after a routine oil change in our shop with the proper oil 5w20. Car returned with SES light on found code PO340. Tech thought car was running fine and cleared code. Car returned two weeks later same code. Checked with ossiloscope ...
September 17, 2005
1995 Nissan Maxima GLE 3.0L Misfire VIN: JN1CA21D1S
P0340: cam position sensor. This is an interesting one. This vehicle came to us from our sister shop across town. They had replaced the components listed below and gave up. Cylinders 2 and 3 have a dead miss and the coils for those cylinders are not receiving a signal to fire from the EC...
September 22, 2005
2000 Oldsmobile Bravada 4.3L Hesitation, MIL Lamp on VIN: 1GHDT13W7Y
P0340: CMP Sensor Circuit Malfunction. ... gauge, stuck in middle. grounded circuit and the gauge pegs. told customer it was the sending unit. she returned the next day saying her check engine light came on after leaving shop. checked codes and got codes p0102 mass air flow sensor voltage too low, ...
September 27, 2005
2004 Chrysler Sebring 2.7L Surge, Cuts out, MIL Lamp on VIN: 1C3EL46R84
P0340: No Camshaft Sensor Signals At PCM. sos to all crysler techs this car is the car from hell , our local boneyard that lets us grab what we need when we need it dropped this bomber on us they got it as a total after a front end wreck that broke clyinder head at cam gear they put a motor from a 03 ...
September 29, 2005
2000 Jeep Cherokee Sport 4.0L MIL Lamp on VIN: 1J4FT48S7Y
P0340: No Camshaft Sensor Signals At PCM. Customer states that he has an intermittent hard start (long cranking with occasional popping noise) in the A.M. for months. The CEL was on with two codes when arrived and cam and crank sensors check out, wave forms appear normal. All wiring and connectors loo...
September 30, 2005